Image Simulation Laboratory Notes

Winter School on High Resolution Electron Microscopy
at Arizona State University
January 4 - 8, 2016

Pierre Stadelmann
JEMS-SAAS
CH-3906 Saas-Fee
Switzerland

December 14, 2015
Starting jems

Start jems student version\(^1\) with this icon:

![Icon](image)

that you see on the desktop. jems main window will open:

Main jems window, Si atoms position (left panel) and [001] projection of one unit cell (right) of Si crystal structure.

\(^1\)http://www.jems-saas.ch
**jems MenuBar: part 1**

- **File menu**: to select a crystal structure.
- **Crystal menu**: to define crystal structures.
- **Drawing menu**: to draw crystal structures, diffraction patterns.
- **Imaging menu**: to perform Blochwave or multislice calculations.

---

File menu: to select a crystal structure. Crystal menu: to define crystal structures. Drawing menu: to draw crystal structures, diffraction patterns. Imaging menu: to perform Blochwave or multislice calculations.
Indexing menu: to index diffraction patterns.

Measuring menu: to measure camera MTF, specimen thickness.

Parameters menu: to configure jems, define microscope or specimen properties.

Miscellany menu: to load or create super-cells.

Menu items that are frequently used are repeated in the ToolBar:

Note that a tool tip text is attached to any jems tool or control. For example:
The left panel displays a tabular list of the silicon atoms.

With the alternate non-centric F d -3 m space group the Si structure contains 8 atoms. Only the atom at Wyckoff position $a$, $(x, y, z) = (0, 0, 0)$, must defined. All the other atom positions are generated by the symmetry operations of the space-group.

- #: atom sequence number.
- Si: atom symbol.
- $a$: Wyckoff position.
- 0.000: $x$ coordinate [0, 1[.
- 0.000: $y$ coordinate [0, 1[.
- 0.000: $z$ coordinate [0, 1[.
- 0.0049: Debye-Waller temperature factor [nm$^2$].
- 1.000: site occupancy [0, 1[.
- 0.029: absorption coefficient.
- Def: charge.
- 0: Atomic Form Factor source (Doyle-Turner or Smith-Burge).
The right panel shows a projection of a silicon unit cell. Note that all atoms of the FCC Bravais lattice are shown.

A mouse click on an atom position labels the atom and a right mouse click displays a popup menu (Ctrl-mouse click on Mac OSX).
Right panel popup menu

Note that a popup menu is attached to many drawings and tables. The popup menu of the right panel allows to:

- **Print**: generates a pdf printout of the drawing.
- **Save**: generates an image of the drawing (using the format defined in the Preferences).
- **Export to Mathematica**: exports the structure as a Mathematica notebook.
- **Show/hide cell frame**: displays or hides the cell frame.
- **Show powder pattern**: uses Debye formula to display a powder pattern.
- **Show HAADF image**: displays a HAADF image (projected potential convoluted with the OTF).
- **Show SAED pattern**: displays a kinematical diffraction pattern (1 unit cell thick crystal).
- **Show WPOA image**: displays a HRTEM image using the Weak Phase Object Approximation (1 unit cell thick crystal).
- **[UVW]** orientation: changes the zone axis.
Si HAADF (FEI Titan pico).

Si powder pattern (randomly oriented Si unit cell).

Si [001] kinematical selected area diffraction pattern.

Si HRTEM image (WPOA) approximation.
jem student edition offers 72 selectable crystal structures. They are available in tabs Cubic, Hexagonal, ... of Select crystal dialogue.

6 different Cubic crystals can be selected. 6 different Other crystals.
Cross the **Save** check box in order to save your preferences.

The preferences dialogue allows to set many jems parameters. Parameters are organised by tabs. The **Imaging** tab contains defaults for image calculations. In order to display structures or images using openGL, enable the Java 3D check box.
Today’s HRTEM image simulation lab

We have already seen how to load or define a crystal structure. I suggest to select the Si crystal structure. With this structure we will learn how to:

- Display the structure with openGL.
- Make a table of structure factors, a powder line plot and how to compare it with X-ray or neutron plots.
- Calculate SAED kinematical and dynamical electron diffraction patterns:
  - with HOLZ lines.
  - with Kikuchi lines.
- HRTEM image simulation:
  - Multislice approach.
  - Blochwave approach.
- Measuring CCD MTF.
- CBED and LACBED.

We will finally learn how to define a super-cell and use it to perform HRTEM image simulation. More information is available in jems ../pdfFiles folder.
Documentation folder contains .pdf files explaining how to perform simulations using jems.
Use **Drawing \(\rightarrow\) Perspective** (or the associated tool button) to display the Si structure in 3-D.

One can change the atom color, size or add bonds, cut the unit cell by parallel (hkl) planes, etc. One can also duplicate the unit cell in order to generate larger unit cells.
Duplicated cell and cut

Select tab [Duplicate], and x, y, z duplications 6, 6, 6. Then push the little hammer tool button.

Under tab [Drawing] select [X] cut and use tab [Plane] to select the (hkl) plane and tab [cut] to cut the structure.
Use **Crystal ➔ Structure factor** to generate a table of structure factors. The table provides the (complex) structure factor, spacing between \((hkl)\) planes, Bragg angle and other useful information.

![Table of structure factors](image)

Use **Reduce** icon to generate the multiplicity of the reflections.
Kinematically forbidden reflections are not tabulated (for example (2,0,0) structure factor is null but the reflection is observed dynamically).
ZOLZ and FOLZ intensities are scaled independently.

Use check box \( \times \) LZ colours of tab Options to define the same scale for all Laue zone reflections. Tab Options allows to add Kikuchi lines, HOLZ lines, colors, etc to the plot.
Dynamical SAED pattern are calculated using the Blochwave approach. Select tab [Crystal/Matrix], radio button [All beams] and [Start]. Change the crystal thickness using the thickness slider.
Two methods:

- **Image calculations using Blochwave approach.**
  1. Best for crystal of small unit cell.
  2. Easy calculations for low symmetry [uvw] directions.
  3. High order Laue zone effects simple to introduce.

- **Image calculations using Multislice approach (Physical optics & periodic continuation).**
  1. Best for crystal of large unit cell or for defects imaged in high symmetry orientation (i.e. [001]).
  2. May require a unit cell transformation to slice crystal $\perp [uvw]$.
  3. Slices must be of the order of $50 \lambda$.

**Imaging $\implies$ Blochwave**

**Imaging $\implies$ Multislice**: how to calculate a map of HRTEM images?
Select the microscope: **Parameters → Microscope**

Select a microscope. When not available, edit a new one +

Aberrations: order selected using **Parameters → Preferences**.

Objective aperture diameter ≥ information transfer.

Optical axis can be moved to simulated dark field images.
Open the multislice dialogue: Imaging ➞ Multislice

HRTEM image calculation by multislice approach.

The HRTEM map tab is automatically selected.

Select ⊙ Envelope in order to introduce effects of partial spatial and temporal coherence.
Select the Imaging tab

HRTEM image calculation by multislice approach.

Imaging tab sets:

1. The defocus between two images of a defocus series and the defocus of the first image (defocus increases).
2. The defocus series size.
3. The image duplication.
Select the Iteration tab

HRTEM image calculation by multislice approach.

Iteration tab sets:

1. The minimum thickness of the specimen (Start after).
2. The number of thickness steps.
3. The thickness between two defocus series images.
4. The total specimen thickness is displayed.
Push Start

start calculates the map.

Notice that:

1. Atomic cols generates cursor mask showing the position of the atomic columns.
2. Plot generates plots of beam amplitude and phase as a function of specimen thickness.
Projected potential

Projected potential of the slice.

Notice that:

- A table of the projected potential can be displayed, printed and exported to Mathematica.
Specimen thickness and defocus are displayed for each image.

Notice that:

- Images are made of 2 x 2 unit cells.
Interactive image calculation and display

Select \( \text{Image} \) and \( \text{Plot} \) and change specimen thickness.

Notice that:

1. Defocus is set in the \textit{Imaging} tab as well as image size.
2. Most important aberrations can be varied in the \textit{Obj. lens} tab.
Redo the map calculation with the ☐ Save wave radio button selected. You will be asked to name the wavefunctions.

Saving the wave functions for further imaging.
Select Imaging ⟷ HRTEM

Load a wave function.
**Imager dialogue:**

The imager dialogue allows to change interactively many HRTEM imaging parameters.
Imager dialogue: wavefunction.
Interactive imaging: Stobbs factor

To see the contrast attenuation due to the camera MTF, change the microscope magnification.

Load camera MTF (ASULabs/cameraMTF.txt)
Wavefront aberrations: **Parameters ➔ Preferences**

Selecting the wavefront aberrations order.

jems can display aberrations to $8^{th}$ order. The order is selected in **Imaging** tab. This tab sets several imaging parameters. The most important are:

1. Pixel size (should not be $\leq 0.01$ nm).
2. Java 3D (should be enable when OpenGL is installed).
3. Lowest beam amplitude considered for imaging ($10^{-6}$ usually).
Wavefront aberrations: Drawing $\Rightarrow$ Transfer function

Dialogue to display wavefront aberration, CTF profile, CTF, Diffractogram, ...
Wavefront aberrations: 2-fold astigmatism

10 nm 2-fold astigmatism (Krivanek: $C_{12}$, Haider $A_1$, Wavefront $W_{22}$).
10 nm 2-fold astigmatism (Krivanek: $C_{12}$, Haider $A_1$, Wavefront $W_{22}$).
The ASULabs folder contains:

1. .cif files (BiFeO3 and FeSiO crystal structures).
2. MTF folder with .dat files for determining the camera MTF (1024, 1024, signed short, Little endian).
3. Gatan images (.dm3)
4. Si3N4 unit cell and super-cell.
5. Folder PtOctahedron with a large super-cell cut into \( \approx 0.2 \) nm slices (PtOct_0000.txt, ...).
Suggestions 1

I suggest you:

1. Open the Si3N4.txt crystal file (File ⇒ Open).
2. Display the structure in 3-D (Drawing ⇒ Perspective).
3. Display the SAED pattern (Drawing ⇒ Diffraction).
4. Do HRTEM image simulation (Imaging ⇒ Multislice) or (Imaging ⇒ Blochwave).
5. Open the Si3N4_supercell.txt crystal file (File ⇒ Open).
6. Display the structure in 3-D (Drawing ⇒ Perspective).
7. Display the SAED pattern (Drawing ⇒ Diffraction).
8. Do HRTEM image simulation (Imaging ⇒ Multislice) using tab Super-cell image. In tab Multislice have the radio buttons ○ Load phase-object and ○ Save phase-object set.

Make sure that aberrations are reset!

Remember that any drawing or table has its own popup menu and that a tip text is attached to any control.
I suggest also that you:

1. Open the PtOct_0000.txt crystal file (of folder PtOctahedron) (File ⇒ Open). It contains the atoms position of the first slice of a large model (Pt octahedron model by Prof. Ernst).

2. Do HRTEM image simulation (Imaging ⇒ Multislice) using tab Super-cell image.

3. Add to the super-cells table all the other slices using ++. You can display the model made of the stack of slices.

4. Make sure that ⊗ Save of tab Iteration-Wavefunction is selected. To see an image after each slice have the ⊗ Show image of tab Iteration selected.

5. Select the first slice of the table (PtOct_0000.txt). Start the calculation (Start). You will be asked to give a name to the wavefunctions files.

6. Load the last wave function in the HRTEMImager (Imaging ⇒ HRTEMImager). Change the imaging parameters in order to how aberrations affect HRTEM images.

\[\text{You can close all the images using Window ⇒ Close All.}\]
USB Key

- Copy the .zip file compatible with your PC operating system.
- Do not open it, but use Extract All in order to unzip the file.
Extracting jems

For Windows 7 after having determine the version 32 (or 64) copy jems32.bat (or jems64.bat) to jems.bat. jems modifies jems.bat.

Figure: Windows 7 or 8 version: jems started either using jems32.bat or jems64.bat depending on Windows being 32 or 64 bits.

Figure: Windows XP (only 32 bits).